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Introduction
Problem Statement

The purpose of this project is to create a Jython programming environment for students.  The environment will be put to use in the 2002 academic year in a new Introduction to Computing class at Georgia Tech.  The target students for the class are those that are not engineering or computer science majors.  Therefore the user interface for the development environment must be easy for people with little programming experience to use.  The user interface must be clearly labeled and free of excess clutter.  The system should be contained inside one window for maximum clarity.  Also, the user will only be allowed to edit one file at a time.  The system will have two text areas, one for editing a file, and the other for access to the Jython interpreter.  The intended use is for a student to write a function in the top editor, then load it and execute it by typing the name of the function in the interpreter window.  The system will attempt to keep novice users from making obvious mistakes.  The system will catch errors thrown by the interpreter and provide comprehensible error messages.  Also, the main debugging option available to users will be a function call that opens a separate window to display the values of the current variables.  The system will provide a Help menu that links to external html help files provided by the client.  These tools should provide the student with the basic things needed to learn how to program in Jython.

The project will be continually revised during its use in class.  Professor Guzdial will maintain the software, and as a result the code must be well documented and extremely readable.  The code must also execute reliably.  The IDE will be implemented in Jython, which runs on a Java Virtual Machine.  This allows the system to be platform independent.  Error messages, as well as other default settings, will be included in a constants file so that they can be easily modified after the release of the project.  The system will provide the basic tools an inexperienced user needs to succeed in the class.  The system will be expandable, since people other than the original authors will modify it at a later date.  The system should be as error free as possible, since many different people will use it on many different platforms.  The final product will be an IDE that is slightly simpler than commercial ones, but will be easier to understand and use for students specifically taking this class. 

Document Overview

Purpose

This document describes the structure and classes of an IDE that is specifically designed for use by students and written in the Jython programming language.

Scope 

This application will be used specifically in a future programming course at The Georgia Institute of Technology by students who are not Computer Science majors.  The application will be used with the Jython programming language, and will be developed with the Jython programming language.  It will provide users with all features needed specifically for the course.

Revised Requirements

· The system must provide a command window with full access to a Jython interpreter, which includes allowing users to enter multi-line commands.

· The system must run on the jdk1.3 Virtual Machine.

· The system must provide a user interface with a box that shows the current line number in the text editor.

· The system must provide a stopAndShowVars() in addition to the showVars() command.  The stopAndShowVars() method must pause the execution of the program until the user clicks the “Continue” button in the JESDebugWindow.

· The system must provide a JESDebugWindow with version numbers.
System Models
Data Model and Functional Model
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Behavioral/Procedural Model
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Conceptual Design
Architecture Diagram 
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Description
The major functionality of this program is provided by two classes: JESUI and JESInterpreter.  JESUI and its related classes are responsible for providing the visual aspect of the development environment.  JESInterpreter provides the access to the Jython interpreter.

JESUI contains instances of two other UI classes, JESEditor and JESCommandWindow.  JESEditor provides a text editing space where users can view and edit their program text.  JESCommandWindow provides a command line window where typed lines are sent to the Jython interpreter and responses are posted.

JESInterpreter executes the command line.  It executes the interpreter in a separate thread so the overall JES program will not block when the user’s code is being interpreted.  JESInterpreter is able to handle any exceptions that are generated by the user’s code.  If an exception occurs, JESInterpreter opens the JESDebugWindow.  It also reports the error message back to the JESCommandWindow.

The JESDebugWindow opens when an exception occurs or when the interpreter executes the showVars() or stopAndShowVars() commands.  It creates a popup window that displays all the variables visible to the interpreter at the point in the program where it was generated.  If stopAndShowVars() was executed, the debug window  contains a “Continue” button, and execution of the interpreter will block until that button is pressed.  The interpreter must be able to execute showVars() and stopAndShowVars() without returning to the main thread.  A copy of the JESDebugWindow will be placed in the namespace of the interpreter, as well as the main thread.

The JESAbout class opens a window that displays version, licensing, and authorship information.

Detailed Design

Data Design 
The purpose of this section is to give a detailed description of the external interfaces of the following classes:


· JESEditor

· JESDebugWindow

· JESCommandWindow

· JESAbout

· JESInterpreter

· JESUI

· JESProgram

· JESAction

· JESCommandWindowDocument

· JESDebugWindowWrapper

· JESEditorDocument

· JESPreprocessing

· JESStdOutputBuffer

· JESThread

· HTMLBrowser

This section will explain the purpose of those objects, and their methods.

JESEditor

The JESEditor class inherits Swing’s JTextPane class, and adds itself as a subwindow to the main window of the JESUI class.  The text area provided by the JESEditor class will allow users to view and edit their programs.  It will allow cut, copy, and paste functionality.  

It will highlight Jython keywords in the text.  This will allow users to easily identify the reserved keywords of Jython, and not try to use those words as names of classes, methods, or variables.

A Jython interpreter will execute the text of the window.  If there is any kind of error at a particular line, the interpreter will tell the editor class, and that line will be highlighted.  This will allow users to easily find their errors.

1. Inheritance

a. The JESEditor class inherits JTextPane. 

2. Variables

a. The JESEditor class contains the following instance variables:

· gui - <NEEDS DESCRIPTION>

· program - <NEEDS DESCRIPTION>

· document - <NEEDS DESCRIPTION>

3. Methods

a. The JESEditor class has the following public methods:

· showErrorLine(lineNumber) - accepts a line number, and highlights that line in the user’s display.  This method will be used to highlight lines that contain errors.

· undo() - <NEEDS DESCRIPTION>

· getScrollableTracksViewportWidth - <NEEDS DESCRIPTION>

· caretUpdate(e) - <NEEDS DESCRIPTION>

· setText(text) - <NEEDS DESCRIPTION>

b. The JESEditor class has the following private methods:

· __init__() – initialize function to create editable text area.

JESDebugWindow

The JESDebugWindow is a debugging tool that allows users to easily see all of the variables and their values in the program at the current location. It inherits Swing’s JFrame class, and pops up either when there is an exception thrown in the interpreter, or when the interpreter sees the showVars() or stopAndShowVars() command in the user’s file.  

The window will list each variable, its type, and its value.  Above the variables, the window will display a timestamp of the call to showVars() or stopAndShowVars().  The window will also display a window number next to the timestamp.  This way, if the user has several calls to showVars() or stopAndShowVars() in his or her program (e.g., inside a loop), he or she can tell in what order the windows appeared.

1. Inheritance

a. The JESDebugWindow class inherits JFrame.

2. Variables

a. The JESDebugWindow class contains the following instance variable:

· title - <NEEDS DESCRIPTION>

3. Methods

a. The JESDebugWindow class has the following public method:

· actionPerformed(event) – creates an action listener for the close (showVars()) or continue (stopAndShowVars()) button at the bottom of the debug window.

b. The JESDebugWindow  class has the following private methods:

· __init__(vars) – initialize function to create pop up window and display current variables and their values.  This method accepts the variables in the current scope from JESInterpreter.

· __buildVarDict__(varsToDisplay) - <NEEDS DESCRIPTION>

JESCommandWindow

The JESCommandWindow class inherits Swing’s JTextPane class, and adds itself as a subwindow to the main window of the JESUI class.  The text area provided by the JESCommandWindow will give users the ability to interact with the Jython interpreter.  It allows users to type commands and see the results without exiting the JES development environment.  It will allow cut, copy, and paste functionality.  

The JESCommandWindow will allow the user to type a command.  When the user hits the ENTER key, the text will be interpreted.  Any results or errors will be displayed to the user.

1. Inheritance

a. The JESCommandWindow class inherits JTextPane.

2. Variables

a. The JESCommandWindow class contains the following instance variables:

· program – a reference to JESProgram that will allow access as needed from the command window.

· gui – a reference to the parent class JESUI that will allow access as needed from the command window.

· currentPos - <NEEDS DESCRIPTION>

· oldPos - <NEEDS DESCRIPTION>

· document - <NEEDS DESCRIPTION>

· isSystem - <NEEDS DESCRIPTION>

· command - <NEEDS DESCRIPTION>

· my_keymap - <NEEDS DESCRIPTION>

3. Methods

a. The JESCommandWindow class has the following public methods:

· getCommandText(text) – gives external class access to the instructions entered by the user.

· showText(text) - <NEEDS DESCRIPTION>

· showError(text) - accepts an error or output string and displays it to the user.  

· paste() - <NEEDS DESCRIPTION>

· pasteHelper() - <NEEDS DESCRIPTION>

· cut() - <NEEDS DESCRIPTION>

· undo() - <NEEDS DESCRIPTION>

· getOldPos() - <NEEDS DESCRIPTION>

· getCurrentPos() - <NEEDS DESCRIPTION>

· getIsSystem - <NEEDS DESCRIPTION>

· makeAction - <NEEDS DESCRIPTION>

· enter() - <NEEDS DESCRIPTION>

· enterHelper() – sends text in command window that was entered before the most recent stroke of the enter key to JESProgram’s runCommand(text) method.

· runCommand() - <NEEDS DESCRIPTION>
· restoreConsole(mode) - <NEEDS DESCRIPTION>

b.   The JESCommandWindow class has the following private methods:

· __init__(program, gui) – initialize function to create editable text area.  This method also takes in a reference to JESProgram and a reference to its parent class, JESUI.

JESAbout

The JESAbout class will inherit Swing’s JFrame class, and display version, authorship, and licensing information to the user.

1. Inheritance

a. The JESAbout class inherits JFrame.

2. Variables

a. The JESAbout class contains no instance variables.

3. Methods

a. The JESAbout class has the following public method:
· actionPerformed(event) - <NEEDS DESCRIPTION>

b. The JESAbout class has the following private method:

· __init__() – initialize function to create pop up window containing authors’ names, version number, and licensing information.

JESInterpreter

The JESInterpreter class inherits Jython’s Thread class.  It will be responsible for executing the text typed in the JESCommandWindow.  When text is in the JESCommandWindow is executed, it will be send to the JESInterpreter.  The interpreted code must be interruptible, and must not block the main program, so the JESInterpreter will create a new thread in which to run the code.  The JESInterpreter will report any errors.

1. Inheritance

a. The JESInterpreter class inherits Thread.

2. Variables

a. The JESInterpreter class contains the following instance variables:

· program – a reference to the parent class JESProgram that will allow access to its methods as needed from the interpreter.

· contextForExecution – a dictionary that holds information out of the file that has been interpreted by Jython.  This variable will contain the function definitions for showVars() and stopAndShowVars() to be used by the interpreter.  This variable will also contain the number in the debug window indicating in what order the windows appeared.

· interpreterLock - <NEEDS DESCRIPTION>

· isLoading - <NEEDS DESCRIPTION>

3. Methods

a. The JESInterpreter class has the following public methods:

· runCommand(compiledCode) – provides external classes the ability to start execution of user text.  This method calls gui’s setRunning(runBool) method and then sends text to the Jython interpreter.  If the command generates an error or output, this method calls sendOutput().

· sendOutput(responseText) – sends output to program.  If the output is simply text, this method calls program’s sendTextToCommandWindow(text) method.  If the output is an exception, this method calls Jython’s vars() method and sends its result toJESDebugWindow’s  __init__(vars) method.  Then it calls program’s sendErrorToCommandWindow(text) method.

· stopThread() - provides external classes the ability to stop program execution.

· load(fileText) – puts information out of the file that has been interpreted in to the contextForInterpreter variable.

· preprocessing() - <NEEDS DESCRIPTION>

· loadHelper(fileText) - <NEEDS DESCRIPTION>

· getExceptionDescription(exception) - <NEEDS DESCRIPTION>

· sendError() - <NEEDS DESCRIPTION>

b. The JESInterpreter class has the following private methods:

· __init__(program) – initialize function to create an engine to interact between the JESCommandWindow and the Jython interpreter.  This method also takes in a reference to its parent class, JESProgram and a reference to JESUI.

JESUI Class
The JESUI class inherits Swing’s JFrame class and creates itself as a main window for the program, filling the entire screen.  In its title bar, the window will display the name of the current file, or Untitled if the file is new.  JESUI will create a menu bar at the top of the main window, a text area underneath the menu bar for editing files, Load and Stop buttons underneath that, and a text area for commands at the bottom of the screen.  Underneath the command text area, JESUI will hold a small status bar, which will display the line number corresponding with the cursor in the editor window.

JESUI will hold the status of the interpreter as it runs commands from the command text area.  If the program is running, then the Load button will be greyed out and the Stop button will be available.  This will indicate to users that their program is still running, so they cannot load a new file, but they can stop the program if it runs longer than it should.  On the other hand, when the program is not running, the Load button will be available to load files, but the Stop button will be greyed out.  This will aid novice users in understanding how the system works, as well as giving them some visual indication that their program is running.

The JESUI class will hold the methods that allow cut, copy, and paste functionality.  This way, text can be moved between the two text areas because JESUI holds an instance of each.  The class contains an action listener method to determine when menu items have been selected.  JESUI will also hold an html browser to open html files that are linked from the Help menu.  

Finally, JESUI will create a dialog box to prompt the user to save his or her file in the editor text area before loading, if he or she has not yet saved.  However, this will only occur when the JESProgram class calls the function after determining that the user did not save before pressing the Load button or before attempting to close the program.

1. Inheritance

a. The JESUI class inherits JFrame.

2. Variables

a. The JESUI class contains the following instance variables:

· editor – an instance of the JESEditor class which will be positioned at the top of the main window.

· commandWindow – an instance of the JESCommandWindow class which will be positioned at the bottom of the main window.

· menu – a menu bar to hold UI menus at the top of the screen.

· fileName – name of the current file displayed in editor.  This variable will be displayed in the title bar of the main window.

· loadButton – a button the user will press to load the file in the editor text area.  This button will be positioned between the editor text area at the top of the main window and the command text area at the bottom of the main window.

· stopButton – a button the user will press to stop an infinite program from running.  This button will be positioned between the editor text area at the top of the main window and the command text area at the bottom of the main window.

· htmlBrowser – a browser that will open html files linked from the Help menu.

· running – a boolean variable that indicates whether or not commands are running in the interpreter.

· program – a reference to the parent class JESProgram that will allow access to its methods as needed from the menus.

· helpBrowser - <NEEDS DESCRIPTION>

3. Methods

a. The JESUI class contains the following public methods:

· copy() – will copy the text currently highlighted on screen to the clipboard, and will leave the highlighted text in place.

· cut() – will copy the text currently highlighted on screen to the clipboard, and will delete the highlighted text from its text area.

· paste() – will check to see if any text is currently highlighted on screen.  If text is highlighted, this method will delete the highlighted text and replace it with the text on the clipboard.  If text is empty, this method will insert the text on the clipboard at the current cursor position.

· undo() – reverses the last text editing action of the user.

· setFileName(fileName) – sets the filename variable to the new file name, and updates the display in the title bar.

· promptSave() – creates a dialog box to prompt the user to save his or her file in the editor text area before loading, if he or she has not yet saved.  The JESProgram class will call this method after determining that the user did not save before pressing the Load button.

· openBrowser(target) – creates an html browser when a help menu item is selected.  This method takes in a variable target that is the link to the specific Help topic requested.

· setRunning(runBool) – takes in a Boolean variable runBool with the status of the interpreter.  This method sets runBool to TRUE if the interpreter thread is currently running a command, and FALSE if it is idle.

· actionPerformed(event) – creates an action listener for the menus and buttons.  For the Edit and Help menus, the appropriate methods within JESUI are called.  For the File menu and the “About…” option on the Help menu, the appropriate methods in program will be called.  For the buttons, Load will call program’s loadFile() method, and Stop will call program’s stopThread() method.  

· exit(event) - <NEEDS DESCRIPTION>

· callTextEditFunction(function) - <NEEDS DESCRIPTION>

· updateRowCol(row,col) - <NEEDS DESCRIPTION>

· setHelpFiles(helpFiles) - <NEEDS DESCRIPTION>

· checkIfHelpTopic(helpTopic) - <NEEDS DESCRIPTION>

b. The JESUI class contains the following private methods:

· __init__(program) – initialize function to create main window and position everything inside.  It will create a menu bar at the top of the main window, a text area (JESEditor) underneath the menu bar for editing files, Load and Stop buttons underneath that, a text area for commands (JESCommandWindow) at the bottom of the screen, and a status bar that contains the current line number.  This method also takes in a reference to its parent class, JESProgram.  

JESProgram Class
The JESProgram class is the core of JES.  On creation, it initializes itself and its instance of the JESUI class, creating the user interface.  It controls an instance of the JESInterpreter class, and allows it to interact with JESUI’s instance of the JESCommandWindow class.

JESProgram handles all options in the File Menu and About Menu from JESUI.  Any options selected from the file menu in JESUI are handled here.  The JESProgram class will check to make sure the file is saved when the user attempts to close the program.  JESUI will prompt the user to save if he or she hasn’t already. The JESProgram class will open an instance of the JESAbout class when the user chooses the About Menu option in JESUI.  

If the Load or Stop buttons are pressed in JESUI, their actions are implemented in JESProgram as well.  After the Load button is pressed, but before the program is loaded, JESProgram checks to ensure that the user saved the file and that the file is indented correctly.  JESUI will prompt the user to save if he or she hasn’t already, and JESProgram will send an error to the JESCommandWindow if the indentation is incorrect.  When the Stop button is pressed, JESProgram will stop the JESInterpreter thread from running, and print a message to its instance of the JESCommandWindow stating that the program was terminated by the user.

JESProgram helps JESCommandWindow interact with JESInterpreter.  When the enter key is pressed in JESCommandWindow, JESProgram will send the text before the enter key to its instance of JESInterpreter.  When JESInterpreter returns an output, JESProgram will send the output text to its instance of JESUI, which will send it to its instance of JESCommandWindow to display.

1. Inheritance

a. The JESProgram class does not inherit any classes.

2. Variables

a. The JESProgram class contains the following instance variables:

· gui – an instance of the JESUI class.

· fileName – the name of the current file.  This variable will be empty when a new file is created before it has been saved.

· interpreter – an instance of the JESInterpreter class.

· textForCommandWindow - <NEEDS DESCRIPTION>

· aboutWindow - <NEEDS DESCRIPTION>

3. Methods

a. The JESProgram class contains the following public methods:

· newFile() – clears the JESEditor text area in gui by calling JESEditor’s setText(text) method and sets fileName to an empty string.  This method calls gui’s setFileName(fileName) method to set the file name in the gui’s title bar to “Untitled”.

· openFile() – prompts the user to select a file to open.  Then this method clears the JESEditor text are in gui and refills it with the text from the selected file, by calling JESEditor’s setText(text) method.  This method then calls gui’s setFileName(fileName) method to update the file name in the gui’s title bar.

· saveFile() – prompts the user to enter a file name if a new file.  This method calls JESEditor’s getText() method to get the new text, which it writes to the file, overwriting the old text.  Then it calls gui’s setFileName(fileName) method to update the file name in the gui’s title bar.

· saveAs() – prompts the user to enter a file name.  This method calls JESEditor’s getText() method to get the new text, which it writes to the file, overwriting the old text.  Then it calls gui’s setFileName(fileName) method to update the file name in the gui’s title bar.

· loadFile() – calls checkForSave() before loading to make sure the file has been saved.  This method calls checkTabs() before loading to make sure that the indentation of the code in the text area is correct.  After that, this method calls load(file) in interpreter.

· checkForSave() - calls promptSave() in gui to prompt the user to save the file if he or she has not already done so.  This method calls JESEditor’s getText() method to get the new text, which it writes to the file, overwriting the old text.  Then it calls gui’s setFileName(fileName) method to update the file name in the gui’s title bar.

· checkTabs() – calls Jython’s method tabNanny() on the current file in fileName to make sure all indentation follows Python standards.  If there is a mistake, an error indicating the problem and the line number of the problem is sent to sendErrorToCommandWindow(text), where text is the error message to print to the JESCommandWindow.

· closeProgram() – calls checkForSave() before closing to make sure the file has been saved, then kills the interpreter thread and closes the gui window.

· stopThread() – calls stopThread() in interpreter to terminate the program currently running from the JESCommandWindow, then calls showTextInCommandWindow(text) to print a message stating that the user has terminated the program.  This method is called when the user presses the Stop button in gui.

· openAboutWindow() – creates an instance of JESAbout, which opens as a pop-up window in gui.  This method is called when the user chooses the “About…” option on the Help Menu in gui.

· setHelpArray() - <NEEDS DESCRIPTION>

· runCommand(text) – calls gui’s setRunning(runBool) method, then calls interpreter’s runCommand(text) method.  Text is the command received from gui’s instance of JESCommandWindow before the enter key was pressed.

· sendTextToCommandWindow(text) – sends text to gui’s instance of JESCommandWindow, calling showText(text).  Text is the information received from interpreter after it executed a command from the JESCommandWindow instance.

· getTextForCommandWindow() - <NEEDS DESCRIPTION>

· sendErrorToCommandWindow(text) – looks up the user-friendly error message listed in JESConstants and sends that to gui’s instance of JESCommandWindow by calling its showError(text) method.  The text variable will contain the new error message, the line number of the code that threw the exception, and the name of the file containing that line of code.  Then this method will call showErrorLine(lineNumber) on the gui’s instance of JESEditor, followed by a call to JESDebugWindow __init__(vars) if the error is not an indentation error.

· sendError() - <NEEDS DESCRIPTION>

b. The JESProgram class contains the following private method:

· __init__() – initialize function.  This method creates JESProgram’s instances of JESUI and JESInterpreter. 

JESAction
<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESAction class inherits AbstractAction.

2. Variables

a. The JESAction class contains the following instance variable:

· name - <NEEDS DESCRIPTION>

3. Methods

a. The JESAction class has the following public method:

· actionPerformed(event) - <NEEDS DESCRIPTION>

b. The JESAction class has the following private method:

· __init__(name) - <NEEDS DESCRIPTION>

JESCommandWindowDocument
<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESCommandWindowDocument class inherits DefaultStyledDocument.

2. Variables

a. The JESCommandWindowDocument class contains the following instance variables:

· command - <NEEDS DESCRIPTION>

· textAttrib - <NEEDS DESCRIPTION>

3. Methods

a. The JESCommandWindowDocument class has the following public methods:

· insertString(offset, str, a) - <NEEDS DESCRIPTION>

· remove(offset, len) - <NEEDS DESCRIPTION>

· getTextAttrib() - <NEEDS DESCRIPTION>

b. The JESCommandWindowDocument class has the following private method:

· __init__(command) - <NEEDS DESCRIPTION>

JESDebugWindowWrapper
<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESDebugWindowWrapper class does not inherit any classes.

2. Variables

a. The JESDebugWindowWrapper class contains the following instance variables:

· count - <NEEDS DESCRIPTION>

· lock - <NEEDS DESCRIPTION>

3. Methods

a. The JESDebugWindowWrapper class has the following public method:

· show(varsToDisplay) - <NEEDS DESCRIPTION>

b. The JESDebugWindowWrapper class ahs the following private method:

· __init__() - <NEEDS DESCRIPTION>

JESEditorDocument
<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESEditorDocument class inherits DefaultStyledDocument

2. Variables

a. The JESEditorDocument class contains the following instance variables:

· editor - <NEEDS DESCRIPTION>

· textAttrib - <NEEDS DESCRIPTION>

· keywordAttrib - <NEEDS DESCRIPTION>

· errorLineAttrib - <NEEDS DESCRIPTION>

· errorLineStart - <NEEDS DESCRIPTION>

· errorLineLen - <NEEDS DESCRIPTION>

3. Methods

a. The JESEditorDocument class has the following public methods:

· insertString(offset, str, a, addUndoEvent) - <NEEDS DESCRIPTION>

· remove(offset, len, addUndoEvent) - <NEEDS DESCRIPTION>

· keywordHighlightEvent(modifiedTextOffset, modifiedTextLen) - <NEEDS DESCRIPTION>

· updateKeywordHighlightInRange(offset, len) - <NEEDS DESCRIPTION>

· setTextAttrib(offset, text) - <NEEDS DESCRIPTION>

· addUndoEvent(eventType, offset, str) - <NEEDS DESCRIPTION>

· undo() - <NEEDS DESCRIPTION>

· showErrorLine() - <NEEDS DESCRIPTION>

b. The JESEditorDocument class has the following private method:

· __init__(editor) - <NEEDS DESCRIPTION>

JESPreprocessing

<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESPreprocessing class does not inherit any classes.

2. Variables

a. The JESPreprocessing class contains no instance variables.

3. Methods

a. The JESPreprocessing class has the following public method:

· showVars() - <NEEDS DESCRIPTION>

c. The JESPreprocessing class has the following private method:
· __getVars__() - <NEEDS DESCRIPTION>

JESStdOutputBuffer

<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESStdOutputBuffer class does not inherit any classes.

2. Variables

a. The JESStdOutputBuffer contains the following instance variables:

· text - <NEEDS DESCRIPTION>

· realBuffer - <NEEDS DESCRIPTION>

· stdOut - <NEEDS DESCRIPTION>

3. Methods

a. The JESStdOutputBuffer has the following public methods:

· restoreOutput() - <NEEDS DESCRIPTION>

· flush() - <NEEDS DESCRIPTION>

· write(newText) - <NEEDS DESCRIPTION>

· getText() - <NEEDS DESCRIPTION>

b. The JESStdOutputBuffer has the following private method:

· __init__(realBuffer) - <NEEDS DESCRIPTION>

JESThread
<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The JESThread class inherits Thread.

2. Variables

a. The JESThread class contains the following instance variables:

· mode - <NEEDS DESCRIPTION> 

· code - <NEEDS DESCRIPTION>

· interpreter - <NEEDS DESCRIPTION>

· contextForExecution - <NEEDS DESCRIPTION>

3. Methods

a. The JESThread class has the following public methods:

· run() - <NEEDS DESCRIPTION>

· stopPython() - <NEEDS DESCRIPTION>

b. The JESThread class has the following private method:

· __init__(code, interpreter) - <NEEDS DESCRIPTION>

HTMLBrowser

<NEEDS CLASS DESCRIPTION>

1. Inheritance

a. The HTMLBrowser class inherits JFrame.

2. Variables

a. The HTMLBrowser class contains the following instance variables:

· status - <NEEDS DESCRIPTION>

3. Methods

a. The HTMLBrowser class has the following public methods:

· buildTopPane(startUrl) - <NEEDS DESCRIPTION>

· goToUrl(event) - <NEEDS DESCRIPTION>

· followHyperlink(hlEvent) - <NEEDS DESCRIPTION>

b. The HTMLBrowser class has the following private method:

· __init__(urlString) - <NEEDS DESCRIPTION>

JESConstants
JESConstants is an external file that contains all the constants the JES program will need.

JESConstants will consist of any extraneous global constants that the program needs, a font size constant, text highlighting constants, a file prepend constant, function definitions for the showVars() and stopAndShowVars() methods, and error messages.

There will be two text highlighting constants.  One constant will contain the color in which the JESEditor class will highlight Jython’s keywords.  The other constant will contain the color in which the JESEditor class will highlight error lines in the user’s code.

The font size constant will be the font size used for both the editor and the command text areas.  As a constant, it can easily be changed so the professor can project text in a size that the students in lecture can read.

The file prepend constant will be a constant string that is prepended to every file that the user loads into the Jython interpreter.  It is a constant so that the string of import statements can be changed as needed.

The function definitions will be declared as a string variable.  After the prepend constant is added to a file, the function definitions will be added.  Then the file’s code will be loaded.  All of these actions will be performed by the JESInterpreter to prepare a user’s file for use in the JESCommandWindow.

When an exception occurs while JES executes a student’s code, the program will give the student a user-friendly description of the error that occurred.  JESConstants will store user-friendly messages as a dictionary with the exception name being the key and the message being the value.  The following table lists all of the exception that JES will initially replace with messages.

	Exception
	User-Friendly Description

	AssertionError
	An “assert” statement has failed.

	AttributeError
	An attempt to access an attribute failed because the object does not contain that attribute.

	EOFError
	The build-in read function failed because the end of the file has been reached.

	FloatingPointError
	A floating-point operation has failed.

	IOError
	An error occurred while attempting to perform an I/O operation.

	ImportError
	An import statement failed to find the module that was defined.

	IndexError
	A list index is out of bounds.

	IndentationError
	A line of code contains bad indentation.

	KeyError
	Attempt to access a key that is not in a dictionary.

	KeyboardInterrupt
	The user pressed the interrupt key.

	MemoryError
	The system does not have enough memory to allocate an object.

	NameError
	A local or global name could not be found.

	NotImplementedError
	A method that was called must be implemented in a sub-class.

	OSError
	An error occurred while making an operating system call.

	OverflowError
	An arithmetic result is outside the range of acceptable values. 

	RuntimeError
	An error occurred while attempting to run the specified code.

	SyntaxError
	A syntax error is contained in the code.

	SystemError
	An internal system error has occurred.

	SystemExit
	A call of the sys.exit() function has been made.

	TypeError
	An attempt was made to call a function on an invalid type.

	UnboundLocalError
	A local name was used before it was created.

	UnicodeError
	An error occurred while encoding or decoding Unicode characters.

	ValueError
	An error occurred attempting to pass an argument to a function.

	WindowsError
	An error occurred while making a Windows system call.

	ZeroDivisionError
	A divide by zero was attempted.


JES also has several exceptions that are used as base classes for all other exceptions.  No error messages will be added for them because they are never raised within Jython code.  These base exception types are:

· StandardError

· ArithmeticError

· LookupError

· EnvironmentError

If an exception type is raised that is not defined with a user-friendly message, then JES will display a more general error message for the user.  That message will say the following:

An error occurred while attempting to run the specified code.

<Message from exception here, retrieved from __doc__ attribute>
Following the user-friendly error message will be a list of the values in the ‘args’ attribute of the exception.  These values will differ depending on the type of exception, but will provide more specific information about the error that occurred.  After that, the line number where the error occurred will be provided.

The user-friendly messages can also contain values that will be replaced by JES before displaying the message.  These values can be any attribute of the exception type that is being raised.  For example, the RuntimeError exception has an attribute called ‘lineno’; if the RuntimeError message contained ‘%(lineno)s’, then that text would be replaced with the actual value of the lineno attribute.

Procedural Design (NOT revised yet)
Scenario: User starts the program.

Assumptions: None.

Description:


User: 

User double-clicks on JES executable.

System: 

The JES executable calls JESProgram’s initialize method, which calls JESInterpreter’s initialize method and JESUI’s initialize method.  JESUI’s initialize method calls JESEditor’s initialize method, which calls JESEditorDocument’s initialize method, and JESCommandWindow’s initialize method, which calls JESCommandWindowDocument’s initialize method.



Code Sequence:



JESProgram



__init__()




JESInterpreter



__init__(program)




JESUI




__init__(program)




JESEditor



__init__()




JESEditorDocument


__init__(editor)




JESCommandWindow

__init__(program, gui)




JESCommandWindowDocument
__init__(command)



Scenario: User chooses Open File from the File Menu.



Assumptions: User has started the program.



Description:

User: 

User chooses Open File from the File Menu, then browses to select her file to open.

System: 

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls JESProgram’s openFile() method, which calls JESEditor’s setText(text) method to set the text in JESEditor to the opened file’s text and JESUI’s setFileName(fileName) method to update the file name in the gui’s title bar.



Code Sequence:




JESUI




actionPerformed(event)




JESProgram



openFile()




JESEditor



setText(text)




JESUI




setFileName(fileName)

Scenario: User chooses New File from the File Menu.



Assumptions: User has started the program.



Description:




User: 

User chooses New File from the File Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls JESProgram’s newFile() method, which calls JESEditor’s setText(text) method to clear the editor window and JESUI’s setFileName(fileName) method to update the file name in the gui’s title bar to “Untitled”.



Code Sequence:



JESUI




actionPerformed(event)




JESProgram



newFile()




JESEditor



setText(text)




JESUI




setFileName(fileName)

Scenario: User chooses Save File from the File Menu.

Assumptions: User has previously opened or created a file.  He may have edited text in the file.



Description:




User:
User chooses Save File from the File Menu, then enters a name for it if it doesn’t already have one.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls JESProgram’s saveFile() method, which calls JESUI’s promptSave() method if necessary, then JESEditor’s getText() method to get the text to save from the editor window.  After that, the saveFile() method calls JESUI’s setFileName(fileName) method to update the file name in the gui’s title bar.



Code Sequence:




JESUI




actionPerformed(event)




JESProgram



saveFile()




JESUI




promptSave()   (if necessary)




JESEditor



getText()




JESUI




setFileName(fileName)

Scenario: User chooses About from the Help Menu.



Assumptions: User has started the program.



Description:




User:





User chooses About from the Help Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls JESProgram’s openAboutWindow() method, which calls JESAbout’s initialize method.



Code Sequence:




JESUI




actionPerformed(event)




JESProgram



openAboutWindow()




JESAbout



__init__()

Scenario: User chooses a help topic from the Help Menu.



Assumptions: User has started the program.



Description:




User:





User chooses a help topic from the Help Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls its openBrowser(target) method, which calls HTMLBrowser’s initialize method to display the html file on the help topic selected.



Code Sequence:




JESUI




actionPerformed(event)




JESUI




openBrowser(target)




HTMLBrowser


__init__(urlString)



Scenario: User chooses Undo from the Edit Menu.



Assumptions: User has edited a file.



Description:




User:

User edits text in a file, then chooses Undo from the Edit Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls its undo() method, which calls either JESCommandWindow’s undo() method or JESEditorDocument’s undo() method to reverse the user’s most recent editing action, depending on which textPane currently has the focus.



Code Sequence:




JESUI




actionPerformed(event)




JESUI




undo()




JESCommandWindow

undo()



OR
JESEditorDocument


undo()



Scenario: User chooses Cut from the Edit Menu.



Assumptions: User has highlighted text in one of the text areas.



Description:




User:

User highlights text in a text area, then chooses Cut from the Edit Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls its cut() method to cut the highlighted text, save it on the clipboard, and remove the highlighted text from the text area.  It calls JESCommandWindow’s cut() method if the command textPane has the focus.  



Code Sequence:




JESUI




actionPerformed(event)




JESUI




cut()




JESCommandWindow

cut()

(if necessary)

Scenario: User selects Copy from the Edit Menu.



Assumptions: User has highlighted text in one of the text areas.



Description:




User:

User highlights text in a text area, then chooses Copy from the Edit Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls its copy() method to copy the text on the clipboard.  (It calls JESCommandWindow’s copy() method if the command textPane has the focus.)



Code Sequence:




JESUI




actionPerformed(event)




JESUI




copy()




(JESCommandWindow

copy()

(if necessary))


Scenario: User chooses Paste from the Edit Menu.

Assumptions: User has cut or copied text in one of the text areas.  She may or may not have highlighted text to replace with the paste action.



Description: 




User:

User either highlights text to replace or positions cursor where she wants to paste text, then chooses Paste from the Edit Menu.




System:

The actionPerformed(event) method in JESUI notices the user’s menu selection and calls its paste() method to either insert the text into the text area at the cursor position or to replace the highlighted text in the text area with the text on the clipboard.  If the command textPane has the focus, JESUI’s paste() method calls JESCommandWindow’s paste() method.



Code Sequence:




JESUI




__actionListener(event)




JESUI




paste()




JESCommandWindow

paste()

(if necessary)



Scenario: User loads a file with proper indentation after saving.



Assumptions: User has entered code in a file and saved it.



Description:




User:





User saves a file, then clicks the Load button.




System:

The actionPerformed(event) method in JESUI notices that the user clicked the Load button and calls JESProgram’s loadFile() method, which calls JESProgram’s checkForSave() method.  After determining that the file is saved, loadFile() calls JESProgram’s checkTabs() function to make sure the file is indented properly.  CheckTabs() calls Jython’s tabNanny() method on the file.  After that, loadFile() calls JESInterpreter’s load(file) method, which calls its getPreprocessingText() method to get the text to prepend to the file, then sends the complete file text to its loadHelper(fileText) method to load the file.



Code Sequence:




JESUI




actionPerformed(event)




JESProgram



loadFile()




JESProgram



checkForSave()




JESProgram



checkTabs()





Jython 




tabNanny()




JESInterpreter



load(file)




JESInterpreter



getPreprocessingText()




JESInterpreter



loadHelper(fileText)

Scenario: User loads a file with indentation errors before saving.

Assumptions: User has edited text in a file, then clicked the Load button.  The file contains at least one indentation error.



Description:




User:

User edits a file, then clicks the Load button.  He enters a file name when prompted to save the file.




System:

The actionPerformed(event) in JESUI notices that the user has clicked the Load button and calls JESProgram’s loadFile() method, which calls JESProgram’s checkForSave() method.  CheckForSave() calls JESUI’s promptSave() method because the file has not yet been saved.  After the user enters a file name, checkForSave() calls JESEditor’s getText() method to get the text from the editor window to save.  Then it calls JESUI’s setFileName(fileName) method to update the file name in the gui’s title bar.  After that, loadFile() calls JESProgram’s checkTabs() method to make sure that the file is indented properly.  CheckTabs() calls Jython’s tabNanny() method on the file.  Since there is an error, checkTabs() will then call JESProgram’s sendErrorToCommandWindow(text) method to report the error.  SendErrorToCommandWindow(text) calls JESCommandWindow’s showError(text) method to display the error and JESEditor’s showErrorLine(lineNumber) method to highlight the line containing the error.



Code Sequence:




JESUI



actionPerformed(event)




JESProgram


loadFile()




JESProgram


checkForSave()




JESUI



promptSave()




JESProgram


saveFile()




JESEditor


getText()




JESUI



setFileName(fileName)




JESProgram


checkTabs()




Jython



tabNanny()




JESProgram


sendErrorToCommandWindow(text)




JESCommandWindow
showError(text)




JESEditor


showErrorLine(lineNumber)

Scenario: User stops the program.

Assumptions: User has loaded a file and executed a command.  Her command execution is currently running.



Description:




User:
User clicks the Stop button while her command is executing.




System:

The action listener in JESUI notices that the user has clicked the Stop button and calls JESProgram’s stopThread() method, which calls JESInterpreter’s stopThread() method to kill the thread and stop the command execution.  Then it calls its showTextInCommandWindow(text) method to print a message in the command window indicating that the user terminated the program.  Finally,  it calls JESUI’s setRunning(runBool) method to inform the gui that the user’s command is no longer executing.



Code Sequence:




JESUI



__actionListener(event)




JESProgram


stopThread()




JESInterpreter


stopThread()




JESProgram


showTextInCommandWindow(text)




JESUI



setRunning(runBool)

Scenario: User’s code calls the showVars() function.

Assumptions:
User has loaded a file containing at least one function that calls showVars().



Description:




User:

User clicks on the Load button, then executes a command on a function in his file containing a call to showVars().




System:

The action listener in JESCommandWindow notices that the user pressed the enter key and calls its enter(self) method, which calls JESProgram’s runCommand(text) method, where text is the text typed into the command window between the last execution and the enter key.  RunCommand(text) calls JESUI’s setRunning(runBool) method to inform the gui that a command is executing, then calls JESInterpreter’s runCommand(text) method.  JESInterpreter’s runCommand(text) method sends text to the Jython interpreter.  When the showVars() call is reached, the interpreter calls Jython’s vars() method and sends the result to JESDebugWindow’s init(self, vars) method to create a debug window.  When the execution is complete, JESInterpreter’s runCommand(text) method calls JESUI’s setRunning(runBool) method to inform the gui that the command is no longer running.



Code Sequence:




JESCommandWindow

__actionListener(self)




JESCommandWindow

__enter(self)




JESProgram



runCommand(text)




JESUI




setRunning(runBool)




JESInterpreter



runCommand(text)




Jython




vars()




JESDebugWindow


__init(self, vars)




JESUI




setRunning(runBool)

Scenario: User enters a command to execute that generates output.



Assumptions: User has loaded a file.



Description:




User:





User clicks the Load button, then executes a command.




System:

The action listener in JESCommandWindow notices that the user pressed the enter key and calls its enter(self) method, which calls JESProgram’s runCommand(text) method, where text is the text typed into the command window between the last execution and the enter key.  RunCommand(text) calls JESUI’s setRunning(runBool) method to inform the gui that a command is executing, then calls JESInterpreter’s runCommand(text) method.  JESInterpreter’s runCommand(text) method sends text to the Jython interpreter.  Since the Jython interpreter returns output, runCommand(text) calls JESInterpreter’s sendOutput() method before it calls JESUI’s setRunning(runBool) method to inform the gui that the command is no longer executing.  SendOutput() calls JESProgram’s sendTextToCommandWindow(text) method (where text is the output), which calls JESCommandWindow’s showError(text) method to display the output in the command window.



Code Sequence:




JESCommandWindow
__actionListener(self)




JESCommandWindow
__enter(self)




JESProgram


runCommand(text)




JESUI



setRunning(runBool)




JESInterpreter


runCommand(text)




JESInterpreter


sendOutput()




JESProgram


sendTextToCommandWindow(text)




JESCommandWindow
showError(text)




JESUI



setRunning(runBool)

Scenario: User enters a command to execute that generates an error.



Assumptions: User has loaded a file.



Description:




User:





User clicks the Load button, then executes a command.




System:

The action listener in JESCommandWindow notices that the user pressed the enter key and calls its enter(self) method, which calls JESProgram’s runCommand(text) method, where text is the text typed into the command window between the last execution and the enter key.  RunCommand(text) calls JESUI’s setRunning(runBool) method to inform the gui that a command is executing, then calls JESInterpreter’s runCommand(text) method.  JESInterpreter’s runCommand(text) method sends text to the Jython interpreter.  Since the Jython interpreter throws an exception, execution stops, and runCommand(text) calls JESInterpreter’s sendOutput() method before calling JESUI’s setRunning(runBool) method to inform the gui that the command is no longer executing.  SendOutput() calls Jython’s vars() method and sends the results to JESDebugWindow’s init(self, vars) method to open a debug window.  Then sendOutput() calls JESProgram’s sendErrorToCommandWindow(text) method (where text is the exception thrown), which looks up the user-friendly error message in JESConstants corresponding to the exception and sends it to JESCommandWindow’s showError(text) method to display the error message in the command window.  SendErrorToCommandWindow(text) then calls JESEditor’s showErrorLine(lineNumber) method to highlight the line with the error.



Code Sequence:




JESCommandWindow
__actionListener(self)




JESCommandWindow
__enter(self)




JESProgram


runCommand(text)




JESUI



setRunning(runBool)




JESInterpreter


runCommand(text)




JESInterpreter


sendOutput()




Jython



vars()




JESDebugWindow

__init(self, vars)




JESProgram


sendErrorToCommandWindow(text)




JESCommandWindow
showError(text)




JESEditor


showErrorLine(lineNumber)




JESUI



setRunning(runBool)

UI Design
JESUI Class

The main user interface of JES is contained in the JESUI class.  The following image shows how the JESUI class will look:
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JESUI is a frame consisting of six major parts:

· Title Bar – identifies the program and the file that is currently open.

· Menu bar – provides options for the user to select for opening, closing, creating, and modifying files, as well as text editing and getting help and information about JES.

· Jython file editor – allows the users to write Jython code to be called from the command window.

· Load and stop buttons – allows the user to load a program or stop the interpreter thread.

· Command window – allows the user to interact with the Jython interpreter and call functions that they have defined in the editor.

· Status bar – displays the row and column where the keyboard cursor is located in the editor.

The Jython file editor will behave as a regular text area, except that it will automatically highlight any Jython keywords by making them bold and blue.  Both the style and color of the keywords will be defined in the JESConstants file, so they can easily be changed if desired.


The Command window will behave similarly to the Jython command line interpreter.  JES will prompt for user input with the ‘>>>’ prompt.  If the user types in a line of code that requires more lines to be entered, then the prompt for the next line will appear as ‘…’.  The command window will allow a user to copy text from anywhere in itself, but will only allow cut and paste operations to be performed on the last line.  Once the user has finished a single line command or a code block, the code will be sent to the interpreter.  

After successfully executing the given code, a message will be displayed in the command window notifying the user that it has finished.  If an exception occurred, then a user-friendly error message will be displayed in the command window and the debug window will appear. Additionally, the line in the editor that contained the error will be highlighted with a red background (this color will also be controllable from the JESConstants file).

When JES is not running, the Load button will be available for users to press and the Stop button will be disabled.   Once the user’s code is sent to the interpreter, the Load button will be disabled and the Stop button enabled.  To provide additional feedback, the normal cursor will be replaced with the hourglass cursor while the interpreter is running.

All of the file manipulation menu options (New, Open, Save, Save As) will be handled with the standard Java file dialog windows.  The following table defines a list of all the menu options that will be available in the top menu bar, as well as the shortcut keys that can be used to access them.

	Menu Bar Category
	Menu Option
	Shortcut

	File
	                New
	Ctrl+N

	File
	Open…
	Ctrl+O

	File
	Save…
	Ctrl+S

	File
	SaveAs…
	Ctrl+Shift+S

	File
	Quit
	Ctrl+Q

	Edit
	Cut
	Ctrl+X

	Edit
	Copy
	Ctrl+C

	Edit
	Paste
	Ctrl+V

	Edit
	Undo
	Ctrl+Z

	Help
	Help
	F1

	Help
	About…
	


One other shortcut, Ctrl-L, will be assigned to the Load button.

JESDebugWindow Class

The Debug window will be a simple frame containing a table and a close or continue button.  The table will list the name, type, and value of each variable that was in the namespace when either the showVars() or stopAndShowVars() function was called.  

The title bar will contain the text ‘JES Debug Window’, followed by a window identifier and the time at which the window was opened.  The window identifier is a number that starts at 1 when a command is sent to the interpreter, and is incremented each time a debug window is opened. This will help the user if they happen to open up more that one debug window at time.
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JESAbout Class

The about class will be a simple frame containing a read-only text area and an OK button.  The text area will contain the required GNU copyright information as well as contact information for the JES program.  Pressing the OK button will close the about window.
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Sources

1. Primary Source: Mark Guzdial, Associate Professor, Georgia Institute of Technology

2. Texts: 

a. Braude, Eric J.  Software Engineering: An Object-Oriented Perspective. United States of America: John Wiley and Sons, Inc., 2001.

b. Eckstein, Robert, Marc Loy, and Dave Wood.  Java Swing. California: O’Reilly & Associates, Inc., 1998.

c. Fowler, Martin, and Kendall Scott.  UML Distilled. United States of America: Addison Wesley Longman, Inc., 2000.

d. Lundh, Fredrik.  Python Standard Library. California: O’Reilly & Associates, Inc., 2001.

e. Pedroni, Samuele, and Noel Rappin.  Jython Essentials. California: O’Reilly & Associates, Inc., 2002.

Appendix
Coding Standards

1. Constants in all capital letters

2. Variables are lowercaseUpperCase

3. Functions are lowercaseUpperCase and begin with verbs

4. Classes begin with Uppercase and are nouns

5. Follow Python indentation – Jython standard is 4 spaces for each indent (don’t use tab stops)

6. 80 characters per line

7. Jython standard method names: __privateMethod()

8. Java Code

a. Opening brace is at end of line of code

b. Closing brace is on its own line

9. Comments

a. In-line – place before the line with the same indentation

b. Function headers

i. ###############################

# Function name:

# Parameters:

#     -param1

#     -param2

# Return:

#      -returnVal1

# Post conditions: (optional, if needed)

# Description:

############################### 


Code Review Methods
1. Each method will be critiqued by at least two team members other than the writer.  Code will be checked for coding standards and readability.

2. All code will be posted on the MediaComp swiki after it has been reviewed by the team.  The swiki is frequently visited by faculty who have an interest in the class.  We will ask the Computer Science faculty visiting the page to review our code and make suggestions and corrections as needed.

